Warning, /libraries/kdb/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 cmake_minimum_required(VERSION 3.0 FATAL_ERROR)
0002 find_package(ECM 1.8.0 REQUIRED NO_MODULE)
0003 set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
0004 include(SetKDbCMakePolicies NO_POLICY_SCOPE)
0005 
0006 project(KDb VERSION 3.2.0) # Update this
0007 
0008 include(KDbAddTests)
0009 include(KDbAddExamples)
0010 kdb_add_tests(OFF)
0011 kdb_add_examples(OFF)
0012 
0013 # ECM
0014 include(ECMGeneratePriFile)
0015 include(ECMInstallIcons)
0016 include(ECMOptionalAddSubdirectory)
0017 include(ECMPoQmTools)
0018 include(ECMSetupVersion)
0019 include(ECMCoverageOption)
0020 include(KDEInstallDirs)
0021 include(KDECMakeSettings NO_POLICY_SCOPE)
0022 include(KDEFrameworkCompilerSettings NO_POLICY_SCOPE)
0023 
0024 # Own
0025 include(KDbCreateSharedDataClasses)
0026 include(KDbGenerateHeaders)
0027 include(KDbMacros)
0028 include(KDbAddQCH)
0029 
0030 simple_option(BUILD_QCH "Build API documentation in QCH format" OFF)
0031 
0032 # Dependencies
0033 set(REQUIRED_QT_VERSION 5.4.0)
0034 set(REQUIRED_KF5_VERSION 5.16.0)
0035 
0036 # Required components to build this framework
0037 # TODO move Widgets-dependent part to a libKDbWidgets
0038 find_package(Qt5 ${REQUIRED_QT_VERSION} NO_MODULE REQUIRED Core Widgets Xml)
0039 find_package(KF5 ${REQUIRED_KF5_VERSION} REQUIRED CoreAddons)
0040 find_package(ICU REQUIRED i18n uc)
0041 set_package_properties(ICU PROPERTIES
0042                        PURPOSE "Required by KDb for unicode-aware string comparisons")
0043 
0044 get_git_revision_and_branch()
0045 add_unfinished_features_option()
0046 add_pc_file(${PROJECT_NAME})
0047 
0048 add_subdirectory(src)
0049 add_subdirectory(tools)
0050 
0051 if(BUILD_TESTING)
0052   add_subdirectory(autotests)
0053   add_subdirectory(tests)
0054 endif()
0055 
0056 add_custom_target(cppclean
0057     COMMAND ${CMAKE_SOURCE_DIR}/tools/cppclean-kdb.sh ${CMAKE_BINARY_DIR}
0058     COMMENT "Running CPPCLEAN"
0059 )
0060 
0061 if (IS_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/po")
0062     ecm_install_po_files_as_qm(po)
0063 endif()
0064 
0065 feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)