Warning, /utilities/symmy/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 # SPDX-License-Identifier: BSD-3-Clause
0002 # SPDX-FileCopyrightText: 2017 Elvis Angelaccio <elvis.angelaccio@kde.org>
0003 
0004 cmake_minimum_required (VERSION 3.16 FATAL_ERROR)
0005 set (CMAKE_CXX_STANDARD 11)
0006 
0007 set(SYMMY_VERSION 1.0.70)
0008 project(symmy VERSION ${SYMMY_VERSION})
0009 
0010 set(KF5_MIN_VERSION 5.71.0)
0011 set(GPGME_MIN_VERSION 1.7.1)
0012 
0013 find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
0014 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
0015 
0016 include(KDEInstallDirs)
0017 include(KDECMakeSettings)
0018 include(KDECompilerSettings NO_POLICY_SCOPE)
0019 include(ECMSetupVersion)
0020 include(ECMQtDeclareLoggingCategory)
0021 include(FeatureSummary)
0022 
0023 # ecm >= 5.31 disables alternative operators, but we use them.
0024 string(REPLACE "-fno-operator-names" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
0025 
0026 find_package(Qt5 CONFIG REQUIRED
0027     Core
0028     Gui
0029     Widgets)
0030 
0031 find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
0032     DocTools
0033     KIO
0034     I18n
0035     WidgetsAddons)
0036 
0037 find_package(Gpgmepp ${GPGME_MIN_VERSION} CONFIG REQUIRED)
0038 find_package(QGpgme ${GPGME_MIN_VERSION} CONFIG REQUIRED)
0039 
0040 ecm_setup_version(PROJECT
0041     VARIABLE_PREFIX SYMMY
0042     VERSION_HEADER symmyversion.h)
0043 
0044 add_definitions(-DTRANSLATION_DOMAIN=\"symmy\")
0045 
0046 add_subdirectory(desktop)
0047 add_subdirectory(src)
0048 add_subdirectory(plugins)
0049 
0050 add_subdirectory(doc)
0051 kdoctools_install(po)
0052 
0053 ki18n_install(po)
0054 
0055 feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)