Warning, /utilities/markdownpart/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 cmake_minimum_required(VERSION 3.16)
0002 
0003 # Release Service version, managed by release script
0004 set (RELEASE_SERVICE_VERSION_MAJOR "22")
0005 set (RELEASE_SERVICE_VERSION_MINOR "11")
0006 set (RELEASE_SERVICE_VERSION_MICRO "70")
0007 set (RELEASE_SERVICE_COMPACT_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}${RELEASE_SERVICE_VERSION_MINOR}${RELEASE_SERVICE_VERSION_MICRO}")
0008 
0009 # Bump MARKDOWNPART_BASE_VERSION once new features are added
0010 set(MARKDOWNPART_BASE_VERSION "0.1")
0011 set(MARKDOWNPART_VERSION "${MARKDOWNPART_BASE_VERSION}.${RELEASE_SERVICE_COMPACT_VERSION}")
0012 
0013 project(markdownpart VERSION ${MARKDOWNPART_VERSION})
0014 
0015 set(QT_MIN_VERSION "5.15.2")
0016 set(KF_MIN_VERSION "5.91.0")
0017 
0018 find_package(ECM ${KF_MIN_VERSION} REQUIRED NO_MODULE)
0019 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
0020 
0021 include(KDEInstallDirs)
0022 include(KDECMakeSettings)
0023 include(KDECompilerSettings NO_POLICY_SCOPE)
0024 include(ECMDeprecationSettings)
0025 include(FeatureSummary)
0026 
0027 find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
0028     Widgets
0029 )
0030 
0031 find_package(KF5 ${KF_MIN_VERSION} REQUIRED COMPONENTS
0032     I18n
0033     Parts
0034 )
0035 
0036 ecm_set_disabled_deprecation_versions(QT 5.15.2
0037     KF 5.91
0038 )
0039 
0040 add_subdirectory(src)
0041 
0042 ki18n_install(po)
0043 
0044 feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)