Warning, /utilities/keditbookmarks/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 cmake_minimum_required(VERSION 3.16)
0002 
0003 # KDE Application Version, managed by release script
0004 set(RELEASE_SERVICE_VERSION_MAJOR "22")
0005 set(RELEASE_SERVICE_VERSION_MINOR "08")
0006 set(RELEASE_SERVICE_VERSION_MICRO "1")
0007 set(RELEASE_SERVICE_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE_VERSION_MINOR}.${RELEASE_SERVICE_VERSION_MICRO}")
0008 
0009 project(keditbookmarks VERSION ${RELEASE_SERVICE_VERSION})
0010 
0011 # ECM setup
0012 set(KF5_MIN_VERSION "5.89.0")
0013 find_package(ECM ${KF5_MIN_VERSION} CONFIG REQUIRED)
0014 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
0015 
0016 set(QT_MIN_VERSION "5.15.2")
0017 
0018 include(KDEInstallDirs)
0019 include(KDECMakeSettings)
0020 include(KDECompilerSettings NO_POLICY_SCOPE)
0021 
0022 include(ECMInstallIcons)
0023 include(ECMSetupVersion)
0024 include(ECMAddTests)
0025 include(ECMQtDeclareLoggingCategory)
0026 include(FeatureSummary)
0027 include(ECMAddAppIcon)
0028 include(KDEGitCommitHooks)
0029 include(KDEClangFormat)
0030 file(GLOB_RECURSE ALL_CLANG_FORMAT_SOURCE_FILES *.cpp *.h *.c)
0031 kde_clang_format(${ALL_CLANG_FORMAT_SOURCE_FILES})
0032 
0033 set(KEDITBOOKMARKS_VERSION "5.97.0")
0034 
0035 find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} REQUIRED COMPONENTS Core)
0036 if (QT_MAJOR_VERSION STREQUAL "6")
0037     find_package(Qt6Core5Compat)
0038 endif()
0039 find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS CoreAddons I18n KIO Bookmarks Parts WindowSystem IconThemes)
0040 find_package(KF5DocTools ${KF5_MIN_VERSION})
0041 set_package_properties(KF5DocTools PROPERTIES DESCRIPTION
0042     "Tools to generate documentation"
0043     TYPE OPTIONAL
0044 )
0045 if(BUILD_TESTING)
0046     find_package(Qt${QT_MAJOR_VERSION}Test ${QT_REQUIRED_VERSION} CONFIG REQUIRED)
0047 endif()
0048 
0049 add_definitions(
0050     -DQT_DISABLE_DEPRECATED_BEFORE=0x050F02
0051     -DQT_DEPRECATED_WARNINGS_SINCE=0x060000
0052     -DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055800
0053     -DKF_DEPRECATED_WARNINGS_SINCE=0x060000
0054 )
0055 
0056 add_subdirectory(src)
0057 ki18n_install(po)
0058 if (KF5DocTools_FOUND)
0059     kdoctools_install(po)
0060     add_subdirectory(doc)
0061 endif()
0062 
0063 feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)
0064 
0065 kde_configure_git_pre_commit_hook(CHECKS CLANG_FORMAT)