Warning, /utilities/kcharselect/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 cmake_minimum_required (VERSION 3.16 FATAL_ERROR)
0002 
0003 # KDE Application Version, managed by release script
0004 set(RELEASE_SERVICE_VERSION_MAJOR "22")
0005 set(RELEASE_SERVICE_VERSION_MINOR "11")
0006 set(RELEASE_SERVICE_VERSION_MICRO "70")
0007 set(RELEASE_SERVICE_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE_VERSION_MINOR}.${RELEASE_SERVICE_VERSION_MICRO}")
0008 
0009 project(kcharselect VERSION ${RELEASE_SERVICE_VERSION})
0010 
0011 set (QT_MIN_VERSION "5.15.0")
0012 set (KF5_MIN_VERSION "5.89.0")
0013 
0014 find_package (ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
0015 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
0016 
0017 include(KDEInstallDirs)
0018 include(KDECMakeSettings)
0019 include(KDECompilerSettings NO_POLICY_SCOPE)
0020 include(ECMSetupVersion)
0021 include(KDEClangFormat)
0022 include(KDEGitCommitHooks)
0023 
0024 find_package (Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
0025     Core
0026     Widgets
0027 )
0028 
0029 find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
0030     Bookmarks
0031     CoreAddons
0032     Crash
0033     I18n
0034     WidgetsAddons
0035     XmlGui
0036 )
0037 
0038 find_package(KF5DocTools ${KF5_MIN_VERSION})
0039 set_package_properties(KF5DocTools PROPERTIES DESCRIPTION
0040     "Tools to generate documentation"
0041     TYPE OPTIONAL
0042 )
0043 
0044 
0045 ecm_setup_version(${RELEASE_SERVICE_VERSION} VARIABLE_PREFIX KCHARSELECT VERSION_HEADER kcharselect_version.h)
0046 
0047 add_definitions(
0048     -DQT_DISABLE_DEPRECATED_BEFORE=0x060000
0049     -DQT_DEPRECATED_WARNINGS_SINCE=0x060000
0050     -DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055900
0051     -DKF_DEPRECATED_WARNINGS_SINCE=0x060000
0052 )
0053 
0054 add_executable(kcharselect)
0055 
0056 target_sources(kcharselect PRIVATE
0057     kcharselectdia.cc
0058     kcharselectdia.h
0059     main.cc
0060 
0061     kcharselect.qrc
0062 )
0063 
0064 target_link_libraries(kcharselect
0065     KF5::Bookmarks
0066     KF5::CoreAddons
0067     KF5::Crash
0068     KF5::I18n
0069     KF5::WidgetsAddons
0070     KF5::XmlGui
0071 )
0072 
0073 install(TARGETS kcharselect ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
0074 
0075 install(FILES org.kde.kcharselect.desktop  DESTINATION ${KDE_INSTALL_APPDIR})
0076 install(FILES org.kde.kcharselect.appdata.xml DESTINATION ${KDE_INSTALL_METAINFODIR})
0077 
0078 if (KF5DocTools_FOUND)
0079     add_subdirectory(doc)
0080     kdoctools_install(po)
0081 endif()
0082 
0083 ki18n_install(po)
0084 
0085 
0086 feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)
0087 
0088 file(GLOB_RECURSE ALL_CLANG_FORMAT_SOURCE_FILES *.cc *.h)
0089 kde_clang_format(${ALL_CLANG_FORMAT_SOURCE_FILES})
0090 
0091 kde_configure_git_pre_commit_hook(CHECKS CLANG_FORMAT)