Warning, /utilities/kbackup/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 cmake_minimum_required(VERSION 3.16.0 FATAL_ERROR)
0002 
0003 # KDE Application Version, managed by release script
0004 set(RELEASE_SERVICE_VERSION_MAJOR "22")
0005 set(RELEASE_SERVICE_VERSION_MINOR "11")
0006 set(RELEASE_SERVICE_VERSION_MICRO "70")
0007 set(RELEASE_SERVICE_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE_VERSION_MINOR}.${RELEASE_SERVICE_VERSION_MICRO}")
0008 
0009 project(kbackup VERSION ${RELEASE_SERVICE_VERSION})
0010 
0011 set(QT_MIN_VERSION "5.15.2")
0012 set(KF5_MIN_VERSION "5.90.0")
0013 
0014 find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
0015 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
0016 
0017 add_definitions(-DTRANSLATION_DOMAIN="kbackup" -DKBACKUP_VERSION="${RELEASE_SERVICE_VERSION}")
0018 
0019 include(KDEInstallDirs)
0020 include(KDECompilerSettings NO_POLICY_SCOPE)
0021 include(KDECMakeSettings)
0022 include(ECMInstallIcons)
0023 include(FeatureSummary)
0024 
0025 find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
0026     Core
0027     Widgets
0028 )
0029 if (QT_MAJOR_VERSION STREQUAL "6")
0030     find_package(Qt6Core5Compat)
0031 endif()
0032 find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
0033     GuiAddons
0034     Notifications
0035     I18n
0036     KIO
0037     XmlGui
0038     IconThemes
0039     Archive
0040     WidgetsAddons
0041 )
0042 find_package(KF5DocTools ${KF5_MIN_VERSION})
0043 set_package_properties(KF5DocTools PROPERTIES DESCRIPTION
0044     "Tools to generate documentation"
0045     TYPE OPTIONAL
0046 )
0047 add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050f00)
0048 add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055900)
0049 
0050 
0051 add_subdirectory(src)
0052 
0053 ki18n_install(po)
0054 if (KF5DocTools_FOUND)
0055     kdoctools_install(po)
0056     add_subdirectory(doc)
0057 endif()
0058 
0059 feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)