Warning, /system/whoopsie-kcm/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 project(kcm-whoopsie)
0002 
0003 cmake_minimum_required(VERSION 2.8.12)
0004 
0005 find_package(ECM 0.0.14 REQUIRED NO_MODULE)
0006 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
0007 
0008 include(FeatureSummary)
0009 include(KDEInstallDirs)
0010 include(KDECMakeSettings)
0011 include(KDECompilerSettings)
0012 
0013 find_package(Qt5 5.0.0 CONFIG REQUIRED DBus)
0014 
0015 find_package(KF5Auth 5.0.0)
0016 find_package(KF5ConfigWidgets 5.0.0)
0017 find_package(KF5Service 5.0.0)
0018 find_package(KF5I18n 5.0.0)
0019 
0020 # KI18N Translation Domain for this library
0021 add_definitions(-DTRANSLATION_DOMAIN=\"kcm-whoopsie\")
0022 
0023 add_subdirectory(src)
0024 
0025 feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)