Warning, /system/partitionmanager/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 # SPDX-FileCopyrightText: 2008 Volker Lanz <vl@fidra.de>
0002 # SPDX-FileCopyrightText: 2014-2022 Andrius Štikonas <andrius@stikonas.eu>
0003 
0004 # SPDX-License-Identifier: GPL-3.0-or-later
0005 
0006 cmake_minimum_required(VERSION 3.16 FATAL_ERROR)
0007 
0008 # KDE Application Version, managed by release script
0009 set (RELEASE_SERVICE_VERSION_MAJOR "22")
0010 set (RELEASE_SERVICE_VERSION_MINOR "11")
0011 set (RELEASE_SERVICE_VERSION_MICRO "70")
0012 set (RELEASE_SERVICE_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE_VERSION_MINOR}.${RELEASE_SERVICE_VERSION_MICRO}")
0013 project(partitionmanager VERSION ${RELEASE_SERVICE_VERSION})
0014 
0015 # Dependencies
0016 set(QT_MIN_VERSION "5.15.0")
0017 set(KF5_MIN_VERSION "5.91")
0018 set(KPMCORE_MIN_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE_VERSION_MINOR}")
0019 
0020 set(KDE_COMPILERSETTINGS_LEVEL "5.85")
0021 
0022 set(CMAKE_USE_RELATIVE_PATHS OFF)
0023 set(CMAKE_BUILD_WITH_INSTALL_RPATH ON)
0024 
0025 find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
0026 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${CMAKE_MODULE_PATH})
0027 include(ECMInstallIcons)
0028 
0029 include(KDEInstallDirs)
0030 include(KDECMakeSettings)
0031 include(KDECompilerSettings NO_POLICY_SCOPE)
0032 include(FeatureSummary)
0033 include(GenerateExportHeader)
0034 
0035 if (NOT QT_MAJOR_VERSION)
0036     set(QT_MAJOR_VERSION "5")
0037 endif()
0038 
0039 find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
0040   Core
0041   Gui
0042   Widgets
0043 )
0044 
0045 # Load the frameworks we need
0046 find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
0047   COMPONENTS
0048     Config
0049     ConfigWidgets
0050     CoreAddons
0051     Crash
0052     DBusAddons
0053     I18n
0054     JobWidgets
0055     KIO
0056     WidgetsAddons
0057     WindowSystem
0058     XmlGui
0059   OPTIONAL_COMPONENTS
0060     DocTools
0061 )
0062 
0063 find_package(PolkitQt${QT_MAJOR_VERSION}-1 REQUIRED)
0064 
0065 add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050f00)
0066 
0067 find_package(KPMcore ${KPMCORE_MIN_VERSION} REQUIRED)
0068 
0069 add_subdirectory(src)
0070 add_subdirectory(icons)
0071 if (KF5DocTools_FOUND)
0072     add_subdirectory(doc)
0073     kdoctools_install(po)
0074 endif()
0075 
0076 ki18n_install(po)
0077 
0078 message(STATUS "KDE Partition Manager ${RELEASE_SERVICE_VERSION} will be built for install into ${CMAKE_INSTALL_PREFIX}")
0079 
0080 feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)