Warning, /system/kalternatives/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
0002 project(kalternatives)
0003 
0004 find_package(ECM REQUIRED NO_MODULE)
0005 set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
0006 
0007 include(KDEInstallDirs)
0008 include(KDECMakeSettings)
0009 include(KDECompilerSettings NO_POLICY_SCOPE)
0010 include(FeatureSummary)
0011 include(ECMInstallIcons)
0012 include(ECMQtDeclareLoggingCategory)
0013 
0014 find_package(Qt5 CONFIG REQUIRED Core Gui Widgets)
0015 
0016 find_package(KF5 REQUIRED
0017    ConfigWidgets
0018    CoreAddons
0019    I18n
0020    IconThemes
0021    KIO
0022    WidgetsAddons
0023 )
0024 
0025 string(TOLOWER "${KALTERNATIVES_DISTRO}" _distro)
0026 set(ABOUT_SUBDIR ${_distro})
0027 if (_distro STREQUAL "dpkg")
0028    set(DISTRO_DPKG TRUE)
0029 elseif (_distro STREQUAL "rpm_2")
0030    set(DISTRO_RPM_2 TRUE)
0031 elseif (_distro STREQUAL "rpm")
0032    set(DISTRO_RPM TRUE)
0033 else ()
0034    message(FATAL_ERROR "A package manager was not set for KAlternatives. Please define KALTERNATIVES_DISTRO with its type (dpkg/rpm/rpm_2).")
0035 endif ()
0036 
0037 add_definitions(-DTRANSLATION_DOMAIN=\"kalternatives\")
0038 add_definitions(
0039    -DQT_DEPRECATED_WARNINGS
0040    -DQT_NO_URL_CAST_FROM_STRING
0041    -DQT_STRICT_ITERATORS
0042    -DQT_USE_QSTRINGBUILDER
0043 )
0044 
0045 feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)
0046 
0047 configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/config-kalternatives.h.cmake
0048                ${CMAKE_CURRENT_BINARY_DIR}/src/config-kalternatives.h)
0049 
0050 add_subdirectory(src)
0051 add_subdirectory(pics)