Warning, /sdk/lokalize/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 # Lokalize project
0002 cmake_minimum_required(VERSION 3.16)
0003 
0004 # KDE Application Version, managed by release script
0005 set (RELEASE_SERVICE_VERSION_MAJOR "23")
0006 set (RELEASE_SERVICE_VERSION_MINOR "03")
0007 set (RELEASE_SERVICE_VERSION_MICRO "70")
0008 set (RELEASE_SERVICE_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE_VERSION_MINOR}.${RELEASE_SERVICE_VERSION_MICRO}")
0009 
0010 project(lokalize VERSION ${RELEASE_SERVICE_VERSION})
0011 
0012 set(QT_MIN_VERSION "5.15.2")
0013 set(KF5_MIN_VERSION "5.90.0")
0014 set(KDE_COMPILERSETTINGS_LEVEL "5.82")
0015 
0016 # search packages used
0017 find_package(ECM ${KF5_MIN_VERSION} REQUIRED CONFIG)
0018 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
0019 include(KDEInstallDirs)
0020 include(KDECMakeSettings)
0021 include(KDECompilerSettings NO_POLICY_SCOPE)
0022 include(ECMAddAppIcon)
0023 include(ECMQtDeclareLoggingCategory)
0024 
0025 find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG REQUIRED Core DBus Widgets Sql)
0026 
0027 find_package(KF5 ${KF5_MIN_VERSION} REQUIRED I18n TextWidgets KIO XmlGui Notifications Config CoreAddons DocTools Sonnet DBusAddons Crash)
0028 
0029 add_definitions(
0030     -DQT_USE_QSTRINGBUILDER
0031     -DQT_NO_CAST_TO_ASCII
0032     -DQT_NO_URL_CAST_FROM_STRING
0033     -DQT_NO_KEYWORDS
0034     -DQT_NO_FOREACH
0035 )
0036 
0037 find_package(HUNSPELL)
0038 set_package_properties(
0039     HUNSPELL PROPERTIES
0040     DESCRIPTION "Library used for stemming"
0041     URL         "https://hunspell.github.io/"
0042     TYPE        REQUIRED 
0043     PURPOSE     "Required to build Lokalize.")
0044 
0045 add_subdirectory(doc)
0046 add_subdirectory(src)
0047 add_subdirectory(scripts)
0048 add_subdirectory(icons)
0049 #add_subdirectory(strigi-analyzer)
0050 
0051 install(FILES org.kde.lokalize.appdata.xml DESTINATION ${KDE_INSTALL_METAINFODIR})
0052 
0053 ki18n_install(po)
0054 kdoctools_install(po)
0055 
0056 feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)