Warning, /sdk/kdesdk-thumbnailers/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 cmake_minimum_required(VERSION 3.16)
0002 
0003 # Release service version, managed by release script
0004 set(RELEASE_SERVICE_VERSION_MAJOR "23")
0005 set(RELEASE_SERVICE_VERSION_MINOR "03")
0006 set(RELEASE_SERVICE_VERSION_MICRO "70")
0007 
0008 set(RELEASE_SERVICE_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE_VERSION_MINOR}.${RELEASE_SERVICE_VERSION_MICRO}")
0009 
0010 project(kdesdk-thumbnailers VERSION ${RELEASE_SERVICE_VERSION})
0011 
0012 set(QT_MIN_VERSION "5.15.0")
0013 set(KF_MIN_VERSION "5.85.0")
0014 
0015 find_package(ECM ${KF_MIN_VERSION} REQUIRED NO_MODULE)
0016 set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules ${ECM_MODULE_PATH})
0017 
0018 include(KDEInstallDirs)
0019 include(KDECMakeSettings)
0020 include(KDECompilerSettings NO_POLICY_SCOPE)
0021 
0022 include(ECMOptionalAddSubdirectory)
0023 include(FeatureSummary)
0024 
0025 find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS Widgets)
0026 find_package(KF5 ${KF_MIN_VERSION} REQUIRED COMPONENTS Config I18n KIO)
0027 
0028 find_package(GettextPO)
0029 set_package_properties("gettext-po"    PROPERTIES
0030                        DESCRIPTION "A library for processing PO files"
0031                        URL         "www.gnu.org/software/gettext"
0032                        TYPE        OPTIONAL
0033                        PURPOSE     "Required to build the PO thumbnailer"
0034 )
0035 
0036 add_definitions(
0037     -DQT_DISABLE_DEPRECATED_BEFORE=0x050F00
0038     -DQT_DEPRECATED_WARNINGS_SINCE=0x060000
0039     -DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055500
0040     -DKF_DEPRECATED_WARNINGS_SINCE=0x060000
0041 )
0042 
0043 if(GETTEXTPO_FOUND)
0044 ecm_optional_add_subdirectory(po_thumbnailer)
0045 endif()
0046 
0047 ki18n_install(po)
0048 
0049 feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)