Warning, /plasma/latte-dock/default.nix is written in an unsupported language. File is not indexed.

0001 { pkgs ? import <nixpkgs> {} }:
0002 
0003 let
0004   inherit (pkgs) stdenv libsForQt5;
0005 in
0006 stdenv.mkDerivation {
0007   pname = "latte-dock";
0008   version = "unstable-9999";
0009 
0010   src = ./.;
0011 
0012   buildInputs = with pkgs; with libsForQt5; [ plasma-framework plasma-wayland-protocols qtwayland xorg.libpthreadstubs xorg.libXdmcp xorg.libSM wayland plasma-workspace plasma-desktop ];
0013 
0014   nativeBuildInputs = with pkgs; with libsForQt5; [ extra-cmake-modules cmake karchive kwindowsystem qtx11extras kcrash knewstuff wrapQtAppsHook ];
0015 
0016   postInstall = ''
0017     mkdir -p $out/etc/xdg/autostart
0018     cp $out/share/applications/org.kde.latte-dock.desktop $out/etc/xdg/autostart
0019   '';
0020 
0021   meta = with pkgs.lib; {
0022     description = "Dock-style app launcher based on Plasma frameworks";
0023     homepage = "https://invent.kde.org/plasma/latte-dock";
0024     license = licenses.gpl2;
0025     platforms = platforms.unix;
0026     maintainers = [ ];
0027   };
0028 }