Warning, /plasma-mobile/qrca/android/build.gradle is written in an unsupported language. File is not indexed.

0001 /*
0002     SPDX-FileCopyrightText: 2018-2020 Volker Krause <vkrause@kde.org>
0003     SPDX-FileCopyrightText: 2019 Nicolas Fella <nicolas.fella@gmx.de>
0004     SPDX-FileCopyrightText: 2020 Gabriel Souza Franco <gabrielfrancosouza@gmail.com>
0005     SPDX-License-Identifier: BSD-3-Clause
0006 */
0007 
0008 buildscript {
0009     repositories {
0010         google()
0011         jcenter()
0012     }
0013 
0014     dependencies {
0015         classpath 'com.android.tools.build:gradle:3.6.4'
0016     }
0017 }
0018 
0019 repositories {
0020     google()
0021     jcenter()
0022 }
0023 
0024 
0025 apply plugin: 'com.android.application'
0026 apply from: '../version.gradle'
0027 def timestamp = (int)(new Date().getTime()/1000)
0028 
0029 dependencies {
0030     implementation fileTree(dir: 'libs', include: ['*.jar', '*.aar'])
0031 }
0032 
0033 android {
0034     /*******************************************************
0035      * The following variables:
0036      * - androidBuildToolsVersion,
0037      * - androidCompileSdkVersion
0038      * - qt5AndroidDir - holds the path to qt android files
0039      *                   needed to build any Qt application
0040      *                   on Android.
0041      *
0042      * are defined in gradle.properties file. This file is
0043      * updated by QtCreator and androiddeployqt tools.
0044      * Changing them manually might break the compilation!
0045      *******************************************************/
0046 
0047     compileSdkVersion androidCompileSdkVersion.toInteger()
0048 
0049     buildToolsVersion androidBuildToolsVersion
0050 
0051     sourceSets {
0052         main {
0053             manifest.srcFile 'AndroidManifest.xml'
0054             java.srcDirs = [qt5AndroidDir + '/src', 'src', 'java']
0055             aidl.srcDirs = [qt5AndroidDir + '/src', 'src', 'aidl']
0056             res.srcDirs = [qt5AndroidDir + '/res', 'res']
0057             resources.srcDirs = ['src']
0058             renderscript.srcDirs = ['src']
0059             assets.srcDirs = ['assets']
0060             jniLibs.srcDirs = ['libs']
0061        }
0062     }
0063 
0064     compileOptions {
0065         sourceCompatibility JavaVersion.VERSION_1_8
0066         targetCompatibility JavaVersion.VERSION_1_8
0067     }
0068 
0069     lintOptions {
0070         abortOnError false
0071     }
0072 
0073     defaultConfig {
0074         minSdkVersion qtMinSdkVersion
0075         targetSdkVersion qtTargetSdkVersion
0076         manifestPlaceholders = [versionName: projectVersionFull, versionCode: timestamp]
0077     }
0078 
0079     packagingOptions {
0080         exclude 'lib/*/*RemoteObjects*'
0081         exclude 'lib/*/*StateMachine*'
0082         exclude 'lib/*/*_imageformats_qico_*'
0083         exclude 'lib/*/*_imageformats_qicns_*'
0084         exclude 'lib/*/*_imageformats_qtga_*'
0085         exclude 'lib/*/*_imageformats_qtiff_*'
0086         exclude 'lib/*/*_qmltooling_*'
0087     }
0088 }