Warning, /packaging/yocto-meta-kf5/recipes-kf5/tier1/ki18n.inc is written in an unsupported language. File is not indexed.

0001 # SPDX-FileCopyrightText: 2014 Johan Thelin <johan.thelin@pelagicore.com>
0002 # SPDX-FileCopyrightText: 2016 S├ębastien Taylor <sebastien@au-zone.com>
0003 # SPDX-FileCopyrightText: 2017-2020 Volker Krause <vkrause@kde.org>
0004 # SPDX-FileCopyrightText: 2020-2021 Andreas Cord-Landwehr <cordlandwehr@kde.org>
0005 #
0006 # SPDX-License-Identifier: MIT
0007 
0008 LICENSE = "LGPL-2.0-or-later & (LGPL-2.1-only | LGPL-3.0-only | LicenseRef-KDE-Accepted-LGPL) & BSD-3-Clause"
0009 PR = "r0"
0010 
0011 DEPENDS:class-native = " \
0012     qtbase \
0013     gettext-native \
0014     extra-cmake-modules-native \
0015 "
0016 DEPENDS:class-target = " \
0017     qtdeclarative \
0018     gettext-native \
0019     extra-cmake-modules \
0020 "
0021 
0022 require ki18n_metainfo.inc
0023 inherit cmake_kf5
0024 inherit cmake_sysroot
0025 inherit python3native
0026 inherit reuse_license_checksums
0027 
0028 EXTRA_OECMAKE:class-native = " -DBUILD_WITH_QTSCRIPT=OFF -DLibIntl_SEARCH_PATH=/usr/include"
0029 
0030 RDEPENDS:${PN}:class-target = " iso-codes"
0031 
0032 FILES:${PN}-dbg += " \
0033     ${libdir}/plugins/kf5/.debug/ktranscript.so \
0034 "
0035 
0036 FILES:${PN} += " \
0037     ${libdir}/plugins/kf5/ktranscript.so \
0038     ${libdir}/qml/org/kde/i18n/localeData \
0039 "