Warning, /packaging/yocto-meta-kf5/recipes-kf5/packagegroups/packagegroup-kde-frameworks5.bb is written in an unsupported language. File is not indexed.

0001 # SPDX-FileCopyrightText: 2019-2020 Volker Krause <vkrause@kde.org>
0002 # SPDX-FileCopyrightText: 2019 Alistair Francis <alistair.francis@wdc.com>
0003 # SPDX-FileCopyrightText: 2020 Andreas Cord-Landwehr <cordlandwehr@kde.org>
0004 #
0005 # SPDX-License-Identifier: MIT
0006 
0007 SUMMARY = "All KDE Frameworks 5 packages"
0008 LICENSE = "MIT"
0009 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
0010 
0011 PACKAGE_ARCH = "${MACHINE_ARCH}"
0012 
0013 inherit packagegroup features_check
0014 
0015 REQUIRED_DISTRO_FEATURES = "wayland x11"
0016 
0017 RDEPENDS:${PN} = " \
0018     attica \
0019     bluez-qt \
0020     breeze-icons \
0021     karchive \
0022     kcalendarcore \
0023     kcodecs \
0024     kconfig \
0025     kcoreaddons \
0026     kdbusaddons \
0027     kdnssd \
0028     kguiaddons \
0029     kholidays \
0030     ki18n \
0031     kidletime \
0032     kimageformats \
0033     kirigami \
0034     kitemmodels \
0035     kitemviews \
0036     kplotting \
0037     kquickcharts \
0038     syntax-highlighting \
0039     kwayland \
0040     kwidgetsaddons \
0041     kwindowsystem \
0042     modemmanager-qt \
0043     networkmanager-qt \
0044     oxygen-icons5 \
0045     prison \
0046     solid \
0047     sonnet \
0048     threadweaver \
0049     \
0050     kactivities \
0051     kauth \
0052     kcontacts \
0053     kcrash \
0054     kdoctools \
0055     kfilemetadata \
0056     kjobwidgets \
0057     knotifications \
0058     kpackage \
0059     kpty \
0060     kunitconversion \
0061     syndication \
0062     \
0063     baloo \
0064     kactivities-stats \
0065     kbookmarks \
0066     kcmutils \
0067     kdav \
0068     kdeclarative \
0069     kded \
0070     kdesu \
0071     kemoticons \
0072     kglobalaccel \
0073     kiconthemes \
0074     kinit \
0075     kio \
0076     knewstuff \
0077     knotifyconfig \
0078     kparts \
0079     kpeople \
0080     krunner \
0081     kservice \
0082     ktexteditor \
0083     ktextwidgets \
0084     kwallet \
0085     kxmlgui \
0086     kxmlrpcclient \
0087     plasma-framework \
0088     purpose \
0089     qqc2-desktop-style \
0090     \
0091     frameworkintegration \
0092     \
0093     kjs \
0094     kjsembed \
0095     kdelibs4support \
0096 "