Warning, /packaging/yocto-meta-kf5/classes/cmake_sysroot.bbclass is written in an unsupported language. File is not indexed.

0001 # SPDX-FileCopyrightText: 2023 Justin Hammond <justin@dynam.ac>
0002 #
0003 # SPDX-License-Identifier: MIT
0004 
0005 
0006 #The Cmake files include the sysroot directory to various library include files, delete the actual sysroot from the path. 
0007 do_install:prepend:class-target() {
0008     if [ "0" -ne $(find . -name \*.cmake | grep '_usr\|Export' | wc -l) ]; then
0009         echo sed -i 's#'${RECIPE_SYSROOT}/usr'#\$\{_IMPORT_PREFIX\}#g' $(find . -name "*.cmake" | grep '_usr\|Export' )
0010         sed -i 's#'${RECIPE_SYSROOT}/usr'#\$\{_IMPORT_PREFIX\}#g' $(find . -name "*.cmake" | grep '_usr\|Export' )
0011     fi
0012 }