Warning, /packaging/yocto-meta-kde/recipes-support/ttf-noto_2019.01.11.bb is written in an unsupported language. File is not indexed.

0001 # SPDX-FileCopyrightText: 2019 Hannah Kiekens <hannahkiekens@gmail.com>
0002 #
0003 # SPDX-License-Identifier: MIT
0004 
0005 DESCRIPTION = "Google Noto fonts"
0006 SECTION = "fonts"
0007 
0008 HOMEPAGE = "https://www.google.com/get/noto/"
0009 LICENSE = "OFL-1.1"
0010 
0011 inherit allarch fontcache
0012 
0013 INHIBIT_DEFAULT_DEPS = "1"
0014 
0015 SRC_URI = "git://github.com/googlefonts/noto-fonts;protocol=https;nobranch=1"
0016 SRCREV = "c30307083469f0c05e216ac75216fd454a517858"
0017 
0018 SRC_URI[md5sum] = "699fd3e70f293e58e628dfbc34ece0b0"
0019 SRC_URI[sha256sum] = "2c55a0422a8d51425dc2f000e7c67139f1d2756ee93568389bdeb8e2c51e1934"
0020 
0021 LIC_FILES_CHKSUM = "file://LICENSE;md5=fce5baa9b16328f04e2afc29f6e4e882"
0022 
0023 S = "${WORKDIR}/git"
0024 
0025 PACKAGES = "ttf-noto"
0026 FONT_PACKAGES = "ttf-noto"
0027 
0028 FILES:${PN}  = " ${datadir}/fonts/truetype/ "
0029 
0030 do_install() {
0031     install -d ${D}${datadir}/fonts/truetype/
0032     find ./hinted/ -name '*.tt[cf]' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \;
0033     find ./unhinted/ -name '*.tt[cf]' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \;
0034 }