Warning, /packaging/yocto-meta-kde/recipes-support/ttf-noto-cjk_2019.03.30.bb is written in an unsupported language. File is not indexed.

0001 # SPDX-FileCopyrightText: 2019 Volker Krause <vkrause@kde.org>
0002 #
0003 # SPDX-License-Identifier: MIT
0004 
0005 DESCRIPTION = "Google Noto CJK fonts"
0006 SECTION = "fonts"
0007 HOMEPAGE = "https://www.google.com/get/noto/"
0008 LICENSE = "OFL-1.1"
0009 LIC_FILES_CHKSUM = "file://LICENSE;md5=55719faa0112708e946b820b24b14097"
0010 
0011 inherit allarch fontcache
0012 
0013 INHIBIT_DEFAULT_DEPS = "1"
0014 
0015 SRC_URI = "git://github.com/googlefonts/noto-cjk.git;protocol=https;nobranch=1"
0016 SRCREV = "9326451d9b4f32ec7f8640581c5053cc192039f2"
0017 S = "${WORKDIR}/git"
0018 
0019 PACKAGES = "ttf-noto-cjk"
0020 FONT_PACKAGES = "ttf-noto-cjk"
0021 
0022 FILES:${PN}  = " ${datadir}/fonts/truetype/ "
0023 
0024 do_compile[noexec] = "1"
0025 
0026 do_install() {
0027     install -d ${D}${datadir}/fonts/truetype/
0028     find ./ -name '*.otf' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \;
0029 }