Warning, /packaging/yocto-meta-kde/recipes-integration/packagegroups/packagegroup-plasma-mobile-workspace.bb is written in an unsupported language. File is not indexed.

0001 # SPDX-FileCopyrightText: 2017-2019 Volker Krause <vkrause@kde.org>
0002 # SPDX-FileCopyrightText: 2019 Alistair Francis <alistair.francis@wdc.com>
0003 # SPDX-FileCopyrightText: 2022 Andreas Cord-Landwehr <cordlandwehr@kde.org>
0004 #
0005 # SPDX-License-Identifier: MIT
0006 
0007 SUMMARY = "KDE Plasma Mobile"
0008 LICENSE = "MIT"
0009 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
0010 
0011 PACKAGE_ARCH = "${MACHINE_ARCH}"
0012 
0013 inherit packagegroup features_check
0014 
0015 REQUIRED_DISTRO_FEATURES = "wayland x11 kde"
0016 
0017 # Qt5's WebEngine requires Python2
0018 WEBENGINE_PACKAGES = " \
0019     discover \
0020 "
0021 
0022 RDEPENDS:${PN} = " \
0023     bluedevil \
0024     breeze \
0025     kactivitymanagerd \
0026     kde-cli-tools \
0027     kdecoration \
0028     kscreen \
0029     kscreenlocker \
0030     kwayland-integration \
0031     kwin \
0032     libkscreen \
0033     libksysguard \
0034     milou \
0035     plasma-integration \
0036     plasma-nano \
0037     plasma-nm \
0038     plasma-pa \
0039     plasma-mobile \
0040     plasma-workspace \
0041     polkit-kde-agent-1 \
0042     powerdevil \
0043     plasma-settings \
0044     plasma-systemmonitor \
0045     xdg-desktop-portal-kde \
0046     kclock \
0047     kweather \
0048     ${@bb.utils.contains('BBFILE_COLLECTIONS', 'python2-layer', '${WEBENGINE_PACKAGES}', '', d)} \
0049 "