Warning, /packaging/yocto-meta-kde/recipes-integration/packagegroups/packagegroup-plasma-bigscreen-workspace.bb is written in an unsupported language. File is not indexed.

0001 # SPDX-FileCopyrightText: 2022 Andreas Cord-Landwehr <cordlandwehr@kde.org>
0002 #
0003 # SPDX-License-Identifier: MIT
0004 
0005 SUMMARY = "KDE Plasma Bigscreen"
0006 LICENSE = "MIT"
0007 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
0008 
0009 PACKAGE_ARCH = "${MACHINE_ARCH}"
0010 
0011 inherit packagegroup features_check
0012 
0013 REQUIRED_DISTRO_FEATURES = "wayland x11 kde"
0014 
0015 # Qt5's WebEngine requires Python2
0016 WEBENGINE_PACKAGES = " \
0017     aura-browser \
0018     discover \
0019 "
0020 
0021 RDEPENDS:${PN} = " \
0022     bluedevil \
0023     breeze \
0024     kactivitymanagerd \
0025     kde-cli-tools \
0026     kdecoration \
0027     kscreen \
0028     kscreenlocker \
0029     kwayland-integration \
0030     kwin \
0031     libkscreen \
0032     libksysguard \
0033     milou \
0034     plasma-integration \
0035     plasma-nano \
0036     plasma-nm \
0037     plasma-pa \
0038     plasma-workspace \
0039     polkit-kde-agent-1 \
0040     powerdevil \
0041     plasma-settings \
0042     xdg-desktop-portal-kde \
0043     ${@bb.utils.contains('BBFILE_COLLECTIONS', 'python2-layer', '${WEBENGINE_PACKAGES}', '', d)} \
0044 "
0045 
0046 RDEPENDS:${PN} += " \
0047     plasma-bigscreen \
0048     plasma-remotecontrollers \
0049     plank-player \
0050 "