Warning, /packaging/yocto-meta-kde-demo/recipes-core/useradd-kde.bb is written in an unsupported language. File is not indexed.

0001 SUMMARY = "Plasma Mobile User Setup"
0002 PR = "r1"
0003 LICENSE = "MIT"
0004 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
0005 
0006 DEPENDS += " \
0007     openssl-native \
0008 "
0009 
0010 S = "${WORKDIR}"
0011 
0012 inherit useradd
0013 
0014 ALLOW_EMPTY:${PN} = "1"
0015 USERADD_PACKAGES = "${PN}"
0016 # salt value 42 chosen arbitrarily
0017 USERADD_PARAM:${PN} = "-d /home/kde -p $(openssl passwd -salt 42 kde) -g user kde"
0018 GROUPADD_PARAM:${PN} = "user; systemd-journal"
0019 
0020 # disable password expire user feature: this would break sddm integration because SDDM can only handle this in the unreleased 1.0 version
0021 perform_passwd_expire() {
0022 }