Warning, /multimedia/kid3/kid3.spec is written in an unsupported language. File is not indexed.

0001 %global gstversion 1.0
0002 
0003 Name:           kid3
0004 Version:        3.9.4
0005 Release:        1%{?dist}
0006 Summary:        Efficient ID3 tag editor
0007 
0008 License:        GPLv2+
0009 URL:            https://kid3.kde.org/
0010 Source0:        https://downloads.sourceforge.net/kid3/%{name}-%{version}.tar.gz
0011 BuildRequires:  kf5-kio-devel
0012 BuildRequires:  kf5-kdoctools-devel
0013 BuildRequires:  kf5-rpm-macros
0014 BuildRequires:  extra-cmake-modules
0015 BuildRequires:  qt5-qtmultimedia-devel
0016 BuildRequires:  cmake
0017 BuildRequires:  id3lib-devel
0018 BuildRequires:  taglib-devel >= 1.4
0019 BuildRequires:  flac-devel
0020 BuildRequires:  libvorbis-devel
0021 BuildRequires:  libchromaprint-devel
0022 BuildRequires:  pkgconfig(gstreamer-%{gstversion})
0023 BuildRequires:  readline-devel
0024 BuildRequires:  gettext
0025 BuildRequires:  libappstream-glib
0026 BuildRequires:  gcc-c++
0027 Requires:       %{name}-common = %{version}-%{release}
0028 
0029 %description
0030 If you want to easily tag multiple MP3, Ogg/Vorbis, FLAC, MPC,
0031 MP4/AAC, MP2, Speex, TrueAudio, WavPack, WMA, WAV, and AIFF files
0032 (e.g. full albums) without typing the same information again and again
0033 and have control over both ID3v1 and ID3v2 tags, then Kid3 is the
0034 program you are looking for.
0035 
0036 %package        common
0037 Summary:        Efficient command line ID3 tag editor
0038 Recommends:     xdg-utils
0039 
0040 %description    common
0041 If you want to easily tag multiple MP3, Ogg/Vorbis, FLAC, MPC,
0042 MP4/AAC, MP2, Speex, TrueAudio, WavPack, WMA, WAV, and AIFF files
0043 (e.g. full albums) without typing the same information again and again
0044 and have control over both ID3v1 and ID3v2 tags, then Kid3 is the
0045 program you are looking for.  The %{name}-common package provides Kid3
0046 command line tool and files shared between all Kid3 variants.
0047 
0048 
0049 %package        qt
0050 Summary:        Efficient Qt ID3 tag editor
0051 Requires:       %{name}-common = %{version}-%{release}
0052 
0053 %description    qt
0054 If you want to easily tag multiple MP3, Ogg/Vorbis, FLAC, MPC,
0055 MP4/AAC, MP2, Speex, TrueAudio, WavPack, WMA, WAV, and AIFF files
0056 (e.g. full albums) without typing the same information again and again
0057 and have control over both ID3v1 and ID3v2 tags, then Kid3 is the
0058 program you are looking for.  The %{name}-qt package provides Kid3
0059 built without KDE dependencies.
0060 
0061 
0062 %prep
0063 %autosetup -p1
0064 
0065 
0066 %build
0067 # lib64 stuff: //bugzilla.redhat.com/show_bug.cgi?id=1425064
0068 %cmake_kf5 \
0069 %if "%{?_lib}" == "lib64"
0070     %{?_cmake_lib_suffix64} \
0071 %endif
0072     -DWITH_GSTREAMER_VERSION=%{gstversion} \
0073     -DWITH_NO_MANCOMPRESS=ON \
0074     .
0075 %make_build
0076 
0077 
0078 %install
0079 
0080 %make_install
0081 
0082 install -dm 755 $RPM_BUILD_ROOT%{_pkgdocdir}
0083 install -pm 644 AUTHORS ChangeLog README $RPM_BUILD_ROOT%{_pkgdocdir}
0084 
0085 %find_lang %{name} --with-man
0086 # --with-kde doesn't work with kf5 yet
0087 # https://github.com/rpm-software-management/rpm/pull/112
0088 mv %{name}.lang %{name}-kde.lang
0089 %find_lang %{name}-qt --with-man
0090 %find_lang %{name}-cli --with-man
0091 %find_lang %{name} --with-qt
0092 for l in en $(ls doc/docs); do \
0093   echo "%%lang($l) %%{_kf5_datadir}/doc/HTML/$l/kid3/" >> %{name}-kde.lang; \
0094   echo "%%lang($l) %%{_docdir}/kid3-qt/kid3_$l.html" >> %{name}-qt.lang; \
0095 done
0096 cat %{name}.lang >> %{name}-cli.lang
0097 cat <<EOF >> %{name}-cli.lang
0098 %%dir %%{_datadir}/kid3/
0099 %%dir %%{_datadir}/kid3/translations/
0100 EOF
0101 
0102 
0103 %check
0104 appstream-util validate-relax --nonet \
0105     $RPM_BUILD_ROOT%{_datadir}/metainfo/*.appdata.xml
0106 
0107 %files -f %{name}-kde.lang
0108 %{_bindir}/kid3
0109 %{_datadir}/metainfo/org.kde.kid3.appdata.xml
0110 %{_datadir}/icons/hicolor/*x*/apps/kid3.png
0111 %{_datadir}/icons/hicolor/scalable/apps/kid3.svgz
0112 %{_datadir}/applications/org.kde.kid3.desktop
0113 %{_datadir}/kxmlgui5/%{name}
0114 
0115 %files common -f %{name}-cli.lang
0116 %{_bindir}/kid3-cli
0117 %{_libdir}/kid3/
0118 %{_datadir}/dbus-1/interfaces/*.xml
0119 %{_datadir}/kid3/qml/
0120 %{_mandir}/man1/kid3.1*
0121 %{_mandir}/man1/kid3-cli.1*
0122 %license COPYING LICENSE
0123 %{_pkgdocdir}/
0124 
0125 %files qt -f %{name}-qt.lang
0126 %{_bindir}/kid3-qt
0127 %{_datadir}/metainfo/org.kde.kid3-qt.appdata.xml
0128 %{_datadir}/applications/org.kde.kid3-qt.desktop
0129 %{_datadir}/icons/hicolor/*x*/apps/kid3-qt.png
0130 %{_datadir}/icons/hicolor/scalable/apps/kid3-qt.svg
0131 %dir %{_docdir}/kid3-qt/
0132 %{_mandir}/man1/kid3-qt.1*