Warning, /multimedia/kamoso/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 cmake_minimum_required (VERSION 3.5 FATAL_ERROR)
0002 
0003 # KDE Application Version, managed by release script
0004 set (RELEASE_SERVICE_VERSION_MAJOR "23")
0005 set (RELEASE_SERVICE_VERSION_MINOR "03")
0006 set (RELEASE_SERVICE_VERSION_MICRO "70")
0007 set (RELEASE_SERVICE_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE_VERSION_MINOR}.${RELEASE_SERVICE_VERSION_MICRO}")
0008 
0009 project(Kamoso VERSION ${RELEASE_SERVICE_VERSION})
0010 
0011 set(KF5_MIN_VERSION 5.70.0)
0012 
0013 find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
0014 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH}  ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
0015 
0016 include(KDECompilerSettings NO_POLICY_SCOPE)
0017 include(KDEInstallDirs)
0018 include(KDECMakeSettings)
0019 include(ECMInstallIcons)
0020 include(ECMAddTests)
0021 include(FeatureSummary)
0022 include(ECMSetupVersion)
0023 
0024 find_package(Qt${QT_MAJOR_VERSION} NO_MODULE REQUIRED COMPONENTS Core Gui Widgets Quick)
0025 find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS Config DocTools KIO I18n Purpose Notifications)
0026 
0027 find_package(PkgConfig REQUIRED)
0028 pkg_check_modules(GStreamer IMPORTED_TARGET gstreamer-1.0)
0029 pkg_check_modules(GStreamerVideo IMPORTED_TARGET gstreamer-video-1.0)
0030 
0031 find_package(KF5Kirigami2)
0032 set_package_properties(KF5Kirigami2 PROPERTIES
0033     DESCRIPTION "A QtQuick based components set"
0034     PURPOSE "Required at runtime"
0035     TYPE RUNTIME
0036 )
0037 
0038 include(ECMQMLModules)
0039 ecm_find_qmlmodule(QtGraphicalEffects 1.0)
0040 ecm_find_qmlmodule(QtQml 2.2)
0041 ecm_find_qmlmodule(QtQuick 2.5)
0042 ecm_find_qmlmodule(QtQuick.Controls 2.2)
0043 ecm_find_qmlmodule(QtQuick.Dialogs 1.0)
0044 ecm_find_qmlmodule(QtQuick.Layouts 1.1)
0045 ecm_find_qmlmodule(QtQuick.Window 2.2)
0046 
0047 add_definitions(-DQT_NO_URL_CAST_FROM_STRING)
0048 
0049 add_subdirectory(src)
0050 add_subdirectory(icons)
0051 add_subdirectory(doc)
0052 
0053 ki18n_install(po)
0054 kdoctools_install(po)
0055 
0056 install(FILES org.kde.kamoso.appdata.xml DESTINATION ${KDE_INSTALL_METAINFODIR})
0057 
0058 feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)