Warning, /maui/mauikit/PKGBUILD is written in an unsupported language. File is not indexed.

0001 pkgname=mauikit-git
0002 pkgver=r210.32b20e6
0003 pkgrel=1
0004 pkgdesc='Utilities and "templated" controls based on Kirigami and QCC2 that follow the ongoing work on the Maui HIG'
0005 arch=(x86_64 i686 arm armv6h armv7h aarch64)
0006 url="https://mauikit.org/"
0007 license=(GPL3)
0008 depends=(qt5-base qt5-declarative qt5-svg qt5-quickcontrols2 kio)
0009 makedepends=(git cmake extra-cmake-modules qt5-webengine)
0010 provides=(mauikit)
0011 conflicts=(mauikit)
0012 source=("${pkgname}::git+https://invent.kde.org/mauikit")
0013 sha256sums=('SKIP')
0014 
0015 pkgver() {
0016   cd "$pkgname"
0017   printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
0018 }
0019 
0020 build() {
0021   cd "$pkgname"
0022   cmake \
0023     -DCMAKE_BUILD_TYPE=Release \
0024     -DCMAKE_INSTALL_PREFIX=/usr \
0025     -DCMAKE_INSTALL_LIBDIR=/usr/lib
0026   make
0027 }
0028  
0029 package() {
0030   cd "$pkgname"
0031   make DESTDIR="$pkgdir" install
0032 }