Warning, /games/ksirk/packaging/ksirk.spec is written in an unsupported language. File is not indexed.

0001 # This spec file was generated using Kpp
0002 # If you find any problems with this spec file please report
0003 # the error to ian geiser <geiseri@msoe.edu>
0004 Summary:   A turn by turn strategy game
0005 Name:      ksirk
0006 Version:   1.8beta1
0007 Release:   0
0008 Copyright: GPL
0009 Vendor:     <The Ksirk Teal>
0010 Url:       http://home.gna.org/ksirk
0011 
0012 Packager:   <Kleag>
0013 Group:     application/games
0014 Source:    ksirk-1.8beta1.tar.bz2
0015 BuildRoot: /tmp
0016 
0017 %description
0018 
0019 
0020 %prep
0021 %setup
0022 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" ./configure \
0023                  \
0024                 $LOCALFLAGS
0025 %build
0026 # Setup for parallel builds
0027 numprocs=`egrep -c ^cpu[0-9]+ /proc/stat || :`
0028 if [ "$numprocs" = "0" ]; then
0029   numprocs=1
0030 fi
0031 
0032 make -j$numprocs
0033 
0034 %install
0035 make install-strip DESTDIR=$RPM_BUILD_ROOT
0036 
0037 cd $RPM_BUILD_ROOT
0038 find . -type d | sed '1,2d;s,^\.,\%attr(-\,root\,root) \%dir ,' > $RPM_BUILD_DIR/file.list.ksirk
0039 find . -type f | sed 's,^\.,\%attr(-\,root\,root) ,' >> $RPM_BUILD_DIR/file.list.ksirk
0040 find . -type l | sed 's,^\.,\%attr(-\,root\,root) ,' >> $RPM_BUILD_DIR/file.list.ksirk
0041 
0042 %clean
0043 rm -rf $RPM_BUILD_ROOT/*
0044 rm -rf $RPM_BUILD_DIR/ksirk
0045 rm -rf ../file.list.ksirk
0046 
0047 
0048 %files -f ../file.list.ksirk