Warning, /games/kshisen/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 cmake_minimum_required(VERSION 3.16 FATAL_ERROR)
0002 
0003 # Release Service version, managed by release script
0004 set(RELEASE_SERVICE_VERSION_MAJOR "22")
0005 set(RELEASE_SERVICE_VERSION_MINOR "11")
0006 set(RELEASE_SERVICE_VERSION_MICRO "70")
0007 set(RELEASE_SERVICE_COMPACT_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}${RELEASE_SERVICE_VERSION_MINOR}${RELEASE_SERVICE_VERSION_MICRO}")
0008 
0009 # Bump KSHISEN_BASE_VERSION once new features are added
0010 set(KSHISEN_BASE_VERSION "1.11")
0011 set(KSHISEN_VERSION "${KSHISEN_BASE_VERSION}.${RELEASE_SERVICE_COMPACT_VERSION}")
0012 
0013 project(kshisen VERSION ${KSHISEN_VERSION})
0014 
0015 set(QT_MIN_VERSION "5.15.0")
0016 set(KF5_MIN_VERSION "5.90.0")
0017 
0018 # Found this somewhere but cannot re-find it now ... but want to investigate later, so keeping this here for now.
0019 #set(CXX_CLANG_TIDY ON)
0020 
0021 find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
0022 
0023 if(ENABLE_CLAZY)
0024     set(CMAKE_CXX_COMPILER clazy)
0025 endif()
0026 
0027 set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules ${ECM_MODULE_PATH})
0028 
0029 include(KDEInstallDirs)
0030 include(KDECMakeSettings)
0031 include(KDECompilerSettings NO_POLICY_SCOPE)
0032 
0033 include(ECMAddAppIcon)
0034 include(ECMInstallIcons)
0035 include(ECMQtDeclareLoggingCategory)
0036 include(ECMSetupVersion)
0037 include(FeatureSummary)
0038 
0039 find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS Core Gui)
0040 
0041 find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
0042     CoreAddons
0043     Config
0044     Crash
0045     DBusAddons
0046     DocTools
0047     XmlGui
0048 )
0049 
0050 find_package(KF5KMahjongglib 5.1.0 REQUIRED)
0051 find_package(KF5KDEGames 7.3.0 REQUIRED)
0052 
0053 add_definitions(
0054     -DQT_DISABLE_DEPRECATED_BEFORE=0x050F00
0055     -DQT_DEPRECATED_WARNINGS_SINCE=0x060000
0056     -DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055900
0057     -DKF_DEPRECATED_WARNINGS_SINCE=0x060000
0058 )
0059 
0060 add_subdirectory(src)
0061 add_subdirectory(icons)
0062 add_subdirectory(sounds)
0063 add_subdirectory(doc)
0064 
0065 install(PROGRAMS org.kde.kshisen.desktop DESTINATION ${KDE_INSTALL_APPDIR})
0066 install(FILES org.kde.kshisen.appdata.xml DESTINATION ${KDE_INSTALL_METAINFODIR})
0067 
0068 ki18n_install(po)
0069 kdoctools_install(po)
0070 
0071 ########### Display Summary ###############
0072 feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)