Warning, /games/kblackbox/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 cmake_minimum_required (VERSION 3.16 FATAL_ERROR)
0002 
0003 # KDE Application Version, managed by release script
0004 set(RELEASE_SERVICE_VERSION_MAJOR "22")
0005 set(RELEASE_SERVICE_VERSION_MINOR "08")
0006 set(RELEASE_SERVICE_VERSION_MICRO "1")
0007 set(RELEASE_SERVICE_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE_VERSION_MINOR}.${RELEASE_SERVICE_VERSION_MICRO}")
0008 
0009 project(kblackbox VERSION ${RELEASE_SERVICE_VERSION})
0010 
0011 set (QT_MIN_VERSION "5.15.2")
0012 set (KF_MIN_VERSION "5.91.0")
0013 
0014 find_package(ECM ${KF_MIN_VERSION} REQUIRED CONFIG)
0015 set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH})
0016 
0017 include(KDEInstallDirs)
0018 include(KDECMakeSettings)
0019 include(KDECompilerSettings NO_POLICY_SCOPE)
0020 
0021 include(ECMInstallIcons)
0022 include(ECMAddAppIcon)
0023 include(ECMSetupVersion)
0024 include(ECMDeprecationSettings)
0025 include(FeatureSummary)
0026 
0027 find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS Widgets Svg)
0028 if (QT_MAJOR_VERSION STREQUAL "6")
0029     find_package(Qt6 ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS SvgWidgets)
0030 endif()
0031 
0032 find_package(KF5 ${KF_MIN_VERSION} REQUIRED COMPONENTS
0033     Archive
0034     CoreAddons
0035     Config
0036     Crash
0037     DocTools
0038     I18n
0039     DBusAddons
0040     TextWidgets
0041     XmlGui
0042 )
0043 
0044 find_package(KF5KDEGames 7.3.0 REQUIRED)
0045 
0046 ecm_set_disabled_deprecation_versions(
0047     QT 5.15.2
0048     KF 5.91
0049     KDEGAMES 7.3
0050 )
0051 
0052 add_subdirectory(pics)
0053 add_subdirectory(doc)
0054 add_subdirectory(icons)
0055 add_subdirectory(src)
0056 
0057 ki18n_install(po)
0058 kdoctools_install(po)
0059 
0060 feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)