Warning, /frameworks/syntax-highlighting/autotests/input/test.bb is written in an unsupported language. File is not indexed.

0001 # syntax test file for Bitbake receipes
0002 
0003 SUMMARY = "GammaRay Qt introspection probe"
0004 HOMEPAGE = "http://www.kdab.com/gammaray"
0005 
0006 LICENSE = "GPLv2"
0007 LIC_FILES_CHKSUM = "file://LICENSE.GPL.txt;md5=2abfe5daa817fd4346b6d55293941415"
0008 
0009 inherit cmake_qt5
0010 
0011 SRC_URI = "git://github.com/KDAB/GammaRay;branch=master"
0012 
0013 SRCREV = "139e003174f48b0c883fc6c200ef2efb7467bff1"
0014 PV = "2.4.0+git${SRCPV}"
0015 
0016 DEPENDS = "qtdeclarative"
0017 
0018 S = "${WORKDIR}/git"
0019 
0020 EXTRA_OECMAKE += " -DGAMMARAY_BUILD_UI=OFF"
0021 
0022 FILES_${PN}-dev += " \
0023     /usr/lib/cmake/* \
0024     /usr/mkspecs/modules/* \
0025 "
0026 FILES_${PN}-dbg += " \
0027     /usr/lib/.debug/* \
0028     /usr/lib/gammaray/*/*/.debug \
0029     /usr/lib/gammaray/*/*/styles/.debug \
0030 "
0031 
0032 do_install_append() {
0033     # multiline string ok here
0034     AVAR="this is
0035 right"
0036 }
0037 
0038 def python_function():
0039     # some python code
0040     pass
0041 
0042 # error: unterinated string
0043 VAR *= "abc
0044   this is wrong