Warning, /frameworks/kactivities/src/imports/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 # vim:set softtabstop=3 shiftwidth=3 tabstop=3 expandtab:
0002 
0003 project (kactivities-imports)
0004 
0005 find_package (Qt${QT_MAJOR_VERSION} REQUIRED NO_MODULE COMPONENTS Gui Qml Quick Sql)
0006 find_package (KF5Config     ${KF_DEP_VERSION} CONFIG REQUIRED)
0007 find_package (KF5CoreAddons ${KF_DEP_VERSION} CONFIG REQUIRED)
0008 
0009 ecm_add_qml_module(kactivitiesextensionplugin URI "org.kde.activities" VERSION 0.1)
0010 
0011 target_sources(kactivitiesextensionplugin PRIVATE
0012    activitiesextensionplugin.cpp
0013    activitymodel.cpp
0014    activityinfo.cpp
0015 #  resourcemodel.cpp
0016    resourceinstance.cpp
0017 
0018    ${KACTIVITIES_CURRENT_ROOT_SOURCE_DIR}/src/utils/dbusfuture_p.cpp
0019 )
0020 
0021 target_link_libraries(
0022    kactivitiesextensionplugin
0023    Qt${QT_MAJOR_VERSION}::Core
0024    Qt${QT_MAJOR_VERSION}::DBus
0025    Qt${QT_MAJOR_VERSION}::Gui
0026    Qt${QT_MAJOR_VERSION}::Qml
0027    Qt${QT_MAJOR_VERSION}::Quick
0028    Qt${QT_MAJOR_VERSION}::Sql
0029    KF5::Activities
0030    KF5::ConfigCore
0031    KF5::CoreAddons
0032    Boost::headers
0033 )
0034 
0035 ecm_finalize_qml_module(kactivitiesextensionplugin DESTINATION ${KDE_INSTALL_QMLDIR})