Warning, /education/khipu/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 project(khipu)
0002 
0003 cmake_minimum_required(VERSION 2.8.12)
0004 
0005 set(KF_MIN_VERSION "5.69.0")
0006 
0007 find_package(ECM ${KF_MIN_VERSION} REQUIRED NO_MODULE)
0008 set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake" ${ECM_MODULE_PATH})
0009 
0010 find_package(Qt5 5.2 REQUIRED NO_MODULE COMPONENTS Widgets Test PrintSupport Xml)
0011 include(KDEInstallDirs)
0012 include(KDECompilerSettings NO_POLICY_SCOPE)
0013 include(KDECMakeSettings)
0014 include(ECMInstallIcons)
0015 include(ECMAddTests)
0016 include(FeatureSummary)
0017 include(ECMAddAppIcon)
0018 
0019 find_package(KF5 ${KF_MIN_VERSION} REQUIRED COMPONENTS I18n ItemModels ItemViews GuiAddons WidgetsAddons NewStuff XmlGui KDELibs4Support DocTools)
0020 find_package(Analitza5 REQUIRED)
0021 
0022 #TODO: enable after adding to store.kde.org
0023 #install(FILES khipu.knsrc DESTINATION  ${CONFIG_INSTALL_DIR})
0024 
0025 
0026 add_definitions(-DQT_NO_URL_CAST_FROM_STRING
0027                 -DQT_NO_CAST_FROM_BYTEARRAY
0028                 -DQT_USE_QSTRINGBUILDER
0029                 -DQT_NO_NARROWING_CONVERSIONS_IN_CONNECT
0030                )
0031 
0032 add_subdirectory(src) #app ... use the library
0033 add_subdirectory(misc) #icons, pics, function library, etc
0034 add_subdirectory(tests)
0035 add_subdirectory(doc)