Warning, /education/kbruch/CMakeLists.txt is written in an unsupported language. File is not indexed.

0001 cmake_minimum_required(VERSION 3.16)
0002 
0003 # KDE Application Version, managed by release script
0004 set(RELEASE_SERVICE_VERSION_MAJOR "23")
0005 set(RELEASE_SERVICE_VERSION_MINOR "03")
0006 set(RELEASE_SERVICE_VERSION_MICRO "70")
0007 set(RELEASE_SERVICE_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE_VERSION_MINOR}.${RELEASE_SERVICE_VERSION_MICRO}")
0008 
0009 project(kbruch VERSION ${RELEASE_SERVICE_VERSION})
0010 
0011 set(QT_MIN_VERSION "5.15.0")
0012 set(KF5_MIN_VERSION "5.92.0")
0013 
0014 find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
0015 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} )
0016 
0017 include(KDEInstallDirs)
0018 include(KDECMakeSettings)
0019 include(ECMDeprecationSettings)
0020 include(KDECompilerSettings NO_POLICY_SCOPE)
0021 
0022 include(ECMAddAppIcon)
0023 include(ECMSetupVersion)
0024 include(ECMInstallIcons)
0025 include(FeatureSummary)
0026 
0027 
0028 find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} CONFIG REQUIRED
0029   Core
0030   Widgets
0031 )
0032 
0033 find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
0034   Config
0035   CoreAddons
0036   Crash
0037   I18n
0038   WidgetsAddons
0039   XmlGui
0040 )
0041 
0042 find_package(KF5DocTools ${KF5_MIN_VERSION})
0043 set_package_properties(KF5DocTools PROPERTIES DESCRIPTION
0044     "Tools to generate documentation"
0045     TYPE OPTIONAL
0046 )
0047 ecm_set_disabled_deprecation_versions(QT 5.15.2  KF 5.101.0)
0048 
0049 kde_enable_exceptions()
0050 
0051 add_subdirectory( src )
0052 
0053 ki18n_install(po)
0054 if (KF5DocTools_FOUND)
0055     kdoctools_install(po)
0056     add_subdirectory(doc)
0057 endif()
0058 
0059 install(FILES org.kde.kbruch.appdata.xml DESTINATION ${KDE_INSTALL_METAINFODIR})
0060 
0061 feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)